NCSC-2022-0358 [1.00] [M/M] Kwetsbaarheid verholpen in PostgreSQL

De ontwikkelaars van PostgreSQL hebben een kwetsbaarheid verholpen in PostgreSQL. Gebleken is dat bepaalde commando's zoals Autovacuum, REINDEX, CREATE INDEX, REFRESH MATERIALIZED VIEW, CLUSTER en pg_amcheck niet correct omgaan met rechten, waardoor een gebruiker deze commando's kan uitvoeren buiten de scope die is toegewezen aan het account. Hierdoor kan een kwaadwillende deze commando's misbruiken om databases te manipuleren waartoe hij niet geautoriseerd is. De kwaadwillende dient hiervoor wel voorafgaande toegang tot het systeem te hebben.
ncsc
13-05-2022 10:49